Jump to content

Photo
- - - - -

R33 Gts25T Popping Under Hard Acceleration


  • Please log in to reply
15 replies to this topic
  • LR33
  • Members
  • Pip
  • 9 posts
  • Car(s):93 R33
  • Real Name:93 R33
Hi all.

Just gave my 93 R33 a run at full throttle from about 60 kmph and it started "popping"

93 R33 gts25t

Only mod is turbo back full exhaust .
Standard boost, no pod.

The popping sounds the same as when it changes gear under heavy acceleration. It started around 5-6000 rpm and lost all power while it was happening.

Could it be?

A, fuel cut.
B, Detonation.
C, Faulty wast gate / Std Bov

I would love some opinions and to hear from anyone who has had this issue and fixed it.

Thanks all.

Posted 07 April 2012 - 12:47 AM


  • LR33
  • Members
  • Pip
  • 9 posts
  • Car(s):93 R33
  • Real Name:93 R33

Hi all.

Just gave my 93 R33 a run at full throttle from about 60 kmph and it started "popping"

93 R33 gts25t

Only mod is turbo back full exhaust .
Standard boost, no pod.

The popping sounds the same as when it changes gear under heavy acceleration. It started around 5-6000 rpm and lost all power while it was happening.

Could it be?

A, fuel cut.
B, Detonation.
C, Faulty wast gate / Std Bov

I would love some opinions and to hear from anyone who has had this issue and fixed it.

Thanks all.


Also it didnt happen anywhere near as much if I accelerated slowly to full throttle still did a couple of pops but held its power.

Posted 07 April 2012 - 03:25 PM


  • mlr
  • Members

  • 5,260 posts
  • Gender:Male
  • Location:My Grid Square
  • Interests:Pina Coladas and getting caught in the rain.
  • Car(s):MX5 NB8A
  • Real Name:Mark
Sounds like a problem, get to a tuner to find the fault before you kill it.

Posted 07 April 2012 - 03:38 PM

This post represents the official view of the voices in my head


  • LR33
  • Members
  • Pip
  • 9 posts
  • Car(s):93 R33
  • Real Name:93 R33

Sounds like a problem, get to a tuner to find the fault before you kill it.


Good tuner on the Goldcoast??

Posted 07 April 2012 - 03:46 PM


  • mad082
  • Contributor

  • 37,929 posts
  • Gender:Male
  • Location:gympie
  • Real Name:marc
sounds like it may be a spark plug/coil issue, or a fuel issue (leaning out)

Posted 07 April 2012 - 06:14 PM

Alright Stop!!1!ty... Hammer Time

Posted Image


marc's right


You're a proper git.


  • toffy
  • Members
  • PipPipPipPipPipPip
  • 2,213 posts
  • Gender:Male
  • Car(s):R33,A31
Coil pack or spark plugs .

Posted 07 April 2012 - 10:55 PM


  • mlr
  • Members

  • 5,260 posts
  • Gender:Male
  • Location:My Grid Square
  • Interests:Pina Coladas and getting caught in the rain.
  • Car(s):MX5 NB8A
  • Real Name:Mark
Fuel filter fuel pump spark plug coil ect ect.

Posted 07 April 2012 - 11:04 PM

This post represents the official view of the voices in my head


  • Gender:Male
  • Car(s):Looking
  • Real Name:Jeremiah
Coil packs, spark plugs or spark plug leads. Same thing happen to my car. You have to gradually increase pressure on the gas but still popping, yea? I changed my coilpacks and all fixed.

Posted 12 April 2012 - 09:11 PM


  • LR33
  • Members
  • Pip
  • 9 posts
  • Car(s):93 R33
  • Real Name:93 R33
Yup you got it. Exactly the same.

Ill start working on the electrical side as soon as i have done the fuel pump.
I changed the filter and it helped a little.

Its going to go something like this,

Fuel Pump, injectors and the things that they include..
then ignition side coil pack, leads plugs.

Im not looking to make it a rocket ship it will just be nice to have it running at full capacity.. (foot to floor no issues)

Posted 14 April 2012 - 12:37 AM


Check your FPR, pull the vac line off it and have a sniff.. If it smells like fuel, then it's a faulty FPR.

I had the same problem as you, but my issue was contaminated fuel..

Could also be a faulty pump.

By the way, do you have a larger pump ? Say a 040 ? If so, they hate 1/4 tanks of fuel lol (well mine does anyway) and it surges on boost..

Posted 14 April 2012 - 01:27 PM


  • LR33
  • Members
  • Pip
  • 9 posts
  • Car(s):93 R33
  • Real Name:93 R33
Firstly im going to get the std pump to 12 v so its running at full pressure and see if that makes a difference. After that ill fit the 040 as the DIY topic explains.

I take it "FPR" is Fuel Pump Return line?or something to that description?? The one that runs from the engine back to the tank past the filter??

Posted 14 April 2012 - 01:39 PM


  • Gender:Male
  • Location:Brisbane
  • Car(s):GTS-T R33
  • Real Name:Kirk
mine did this ages ago 2 times, 1st time was spark plugs, 2nd time was crappy fuel.....havent had a prob since

Posted 16 April 2012 - 07:02 PM


  • Car(s):R33
  • Real Name:drew wollin
had similar problem after fitting 3" hi flow cat. changed plugs to iridium and reduced gap slightly 0.9 mm i think, smaller gap better when combustion pressures are higher as fuel harder to ignite. gave coil packs a good clean as there was carbon around them. ran fine then. drew

Posted 04 May 2012 - 02:24 PM


  • Location:Gold Coast
  • Car(s):R33 GTS-t
  • Real Name:Brad
+1 for coil packs, good tuner on the coast Gavin wood Autotech 55292313

Posted 04 May 2012 - 02:27 PM

Successful traders: Slide, Dezz, Shy_s6, Nevastator,SmurFFF, Coaster, zeed_zagged

  • Gender:Male
  • Location:melbourne
  • Car(s):EVO VII
  • Real Name:Hamish
Posted Image


take 6 and call me in the morning

Posted 04 May 2012 - 05:12 PM

Posted Image

  • LR33
  • Members
  • Pip
  • 9 posts
  • Car(s):93 R33
  • Real Name:93 R33
woo how much??

Posted 05 May 2012 - 02:38 PM





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users